Обновление NextCloud 15.0.x на 16.0.x

Автор: | 25.11.2019

“Вы используете PHP 7.0.22-0ubuntu0.16.04.1. Рекомендуется обновить версию PHP”
Для установки версии 16.0.x требуется минимальная версия PHP 7.1
Идём на сервер, добавляем репозиторий PPA Ondřej Surý:

Возможно потребуется установка:

Начинается установка свежего ядра, а места на /boot свободного нет, никакая команда не помогает, т.к. сразу же запускается установка ядра и всё по кругу …

Получил список старых ядер
dpkg -l linux-image-* | grep ii | grep -v [a-z]-generic | grep -v uname -r | awk '{ print $2 }'

Попытался удалить ненужные ядра командой dpkg -P linux-image-*
dpkg -P linux-image-4.4.0-98-generic
не помогло …

Физически удалил несколько старых ядер и хейдеров, запустилось восстановление …
Далее …
apt-get autoremove --purge

Далее удалил все ядра кроме действующего и последнего:

В конце:

Перегружаем сервер.

Устанавливаем PHP 7.2 и необходимые модули:

Наконец то появилась возможность обновиться

Добавить комментарий

Ваш e-mail не будет опубликован.

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.