Настройка в MikroTik iptv и uPnP

Автор: | 19.06.2015

Как настроить iptv?
В микротике есть поддержка igmp-прокси. Чтобы пробросить весь iptv-траффик внутрь сети, надо сделать так:

/routing igmp-proxy interface add alternative-subnets=0.0.0.0/0 disabled=no interface=pppoe-uplink threshold=1 upstream=yes
/routing igmp-proxy interface add disabled=no interface=bridge threshold=1 upstream=no

немного подробностей:
первая строка — interface=pppoe-uplink — это PPPoE интерфейс, upstream говорит модему о том что iptv должен идти с этого интерфейса.
вторая — interface=bridge — это основной LAN интерфейс, там, где у вас висит DHCP-сервер. Обратите внимание что в данном случае upstream=no — те так мы указываем что это клиенты.
Как настроить upnp?
Если порты пробрасывать лень, а клиент поддержкивает uPnP (автоматическую настройку портов) то можно просто настроить на микротике uPnP. Более того, для игры в современне онлайн-игры uPnP жизненно необходим.

/ip upnp set allow-disable-external-interface=no enabled=yes show-dummy-rule=yes
/ip upnp add disabled=no interface=bridge type=internal
/ip upnp add disabled=no interface=pppoe-uplink type=external

Первой строкой включаем uPnP, второй — указываем внутренний порт (где dhcp сервер, опять же — interface=bridge) и говорим что это внутренний (LAN) (type=internal)
Третьей указываем внешний интерфейс (должен же микротик знать куда ему порты пробрасывать) — interface=ppppoe-mgts — и говорим что это внешний (type=external)

Добавить комментарий

Ваш e-mail не будет опубликован.